DynaShape


#104

As far as the exe it got installed but is not showing up on the library


#105

There is no need for dyf files.

Can you take a screenshot of the Dynamo packages directory? Thanks


#106

sure …!
here it is .


#107

I noticed there are two DynaShape folder. Can you try deleting the one without the underscore?


#108

did that too but doesn’t work but, I copied the packages to dynamo 2.0 folder and it works with dyanmo 2.0


#109

also as reported by few people here I have this issue too…


#110

The issue with the node Utilities.RectangularGrid is that, on some computers, the default value for the input “cs” does not work correctly (and I still have not figured out why as I have not been able to reproduce this error on my own computer)

A simple way to fix is to feed an actual a coordinate system to this input

This will probably also fixes the error with the Solver.Execute node.

Let me know how it goes :slight_smile:


#111

Also I just updated the installer to version 0.5.0.74. Please try that as well if the problem still persists


#112

Hi @LongNguyen, Thank you so much for your help.
Initially it seemed to work and the problem with “Utilities.RectangularGrid” is resolved but solver is still showing me an error,Since i haven’t worked with dynashape earlier I am not even able to guess why this error pops up
Do you have any solution? Already tried uninstall an reinstall thrice.
Thanks.


#113

That’s strange. This type of issue should have already been addressed in the latest version.
Can you confirm which version of DynaShape you are running?
Also, it probably still works even with this error (try setting reset to “False” and “Execute” to true to see if the geometies in the background start moving)


#114

Thank you so much , the error still shows up but ,geometry worked as you mentioned …!
thank again…!

Only thing that keep me still worried is how Am I going to export the final geometry if it shows such error…?


#115

Oh…! forgot this Iam using DynaShapeSetup_0.5.0.63


#116

Thanks. I am still trying to hunt down the cause of the error.

But as far as I can tell it wont cause any real problem, just the annoying warning message

You can still produce real Dynamo geometries for further use downstream. Just pause the solver (set “execute” to False) and set “fastDisplay” to False


#117

BTW, the latest version is 0.5.0.74. This should fix the null pointer problem above (at least on the computers that I have tested on)


#118

Anyone please tell me what am I missing here…


Thanks in advance!


#119

This file btw is a downloaded sample


#120

Short answer: feed a WorldXY coordinate system into the input “cs” of the node Utilities.RectangularGrid

For more explanation see post 106 above


#121

Amazing Job …:no_mouth::no_mouth::no_mouth: speechless - Where can I can find the AuxeticRotatingSquare file ? Can’t find it on the examples, maybe it wasn’t provided…


#122

That file is included in the latest example set. It is in the first post.


#123

error

I still have an error on that one… notice that I tried to change my user name manually but that didn’t work…