DynaShape


#64

LongNguyen, great work! Look forward to using. When I place the solver, it doesn’t run and gives me the following error message: “Warning: Solver.Create operation failed. Oh no. DynaShape could not get access to the Helix ViewModel. Sad!”

Revit 2017.2, Dynamo 1.3.1. I installed the package manually.

best, Nick


#65

@Nick_Curtis did you update the DynaShape_ViewExtensionDefinition.xml file so that it points correctly to the DynaShape.dll file inside the package folder followed by placing the xml into [DynamoCoreMainFolder]\viewExtensions and restarting Dynamo


#66

MeshToolkit + DynaShape Full Video

giphy


#67

hehe
Người việt nam anh ơi


#68

Great,Just awesome.:grinning::heart_eyes::sunglasses:


#69

As others have said: Fantastic!
But on my set-up, like @Julien_Benoit1, I had to supply real inputs to the defaults for Utilities.RectangularGrid, Goals.ConstantGoal_Create, etc. Otherwise I got ‘Dereferencing a non-pointer’ errors on those nodes.
Just an idea: Maybe because we are on Metric Revit??


#70

Actually I did not have this problem on my computer. But it exists on some other computers. Looks like the default value does not work properly. I don’t think it’s related to metric system. Thanks for reporting the issue on you computer. Will looks into this.


#71

@LongNguyen
.
Hi Long;
I,ve got challenge with Dynashape. How could I solve it?
.


#72

I’m having the same problem.


#73

Please try to reinstall. This is usually caused by an xml file not being installed correctly


#74

After several attempts, I finally got DynaShape to show up in Dynamo as well as in the package manager > Previously Dynashape was only visible in the package manager). Now I’m faced with “operation failed” warnings. I’m using Dynamo 1.3.2. Any advice on how to get it working?


How to create a bulge shape?
#75

Can you please who the error message in the Solver.Create node.


#76

The Solver.Create node says “Warning: Solver.Create operation failed.
Oh no, DynaShape could not get access to the Helix ViewModel. Sad!”
image


#77

Hello!

Thank you for the amazing job! I was wondering, is there a component to generate spring forces?
I would like to create something similar to the image below, a network of hexagonal patterns with some variation, and using spring forces is the first thing that I thought of.

nervous

Any idea about how could I achieve this using DynaShape?

Thanks!


#78

I can imagine you can probably achieve something similar that in a more direct way, without using springs or a solver like DynaShap.

But if you want to try DynaShape, then yes you can simulate virtual springs using the LengthGoal

To achieve something similar to that screenshot, You can treat the anchor points as vertices in DynaShape. Then create the following goals for the DynaShape solver.

  1. For every node, create an Anchor goal that tries to keep them in the original positions. The weight for the Anchor goals associated with the attractor point must be very high compared to other anchor goals
  2. For every vertex, create Length goals that link them to each attractor points. The targetLength might be set to half of the original length (i.e. the distance between the vertex and the attractor)
  3. Run the solver and hopefully you will see the length goals pull the vertices toward the attractor points, while the anchor goals will try to slightly pull them back to original positions (without the anchor goals, all the vertices will likely to move too much and becomes chaotic.

#79

Hi Long,

thanks for the answer! I have tried to do what you suggested, but I might have done something wrong because when I run the solver the grid disappear… Can you see what I am missing?

Thanks for your time!


#80

Here is my setup Attractor.dyn (37.1 KB)

You will notice that it is actually a bithard to tweak the parameters to get the right attraction blending ratio and falloff between multiple attractors.

In fact, there are better analytical algorithms (e.g. thin-plate-splines, FFD/Freeform deformation) that can achieve this kind of non-linear space deformation directly without the need for an iterative algorithm like the one used inside DynaShape


#81

Thank you very much Long!


#82

Hi Long,
I’ve installed dynashape and tried some example files. 6,7 and 8 works but 1 to 5 don’t . I always get this error message for the Constantgoal_create component : “Dereferencing a non-pointer”
I also get this message after reinstalling it manually.
Do you know what could be wrong?
Thanks


#83

I’m not @LongNguyen but I might have an answer for you:
To my knowledge that kind of error generally happen because there’s an issue with the list structure. Are you using several lists as input? Have you tried it with just one input?
If the latter would solve your issue I’d say try solving it with a List.Map.