DynaShape


#43

@LongNguyen - I know there are constast length goals, but those only accept straight lines. I would like to set a goal of a constant length along a polycurve (2 straight lines whose sum of lengths is constant) to simulate a cable going over a pulley. Possible?


#44

I don’t think that can readily be done yet. Will need a dedicated goal for that.


#45

Hi @LongNguyen
I have one issue, Solver.Create node shows an error that “Could not get access to the viewport :(”.What Can I do?


#46

Did you use the installer or manual setup method? Most likely the error is caused by the DynaShape_ViewExtension.xml file not being set up correctly.


#47

I tried installer first,then manual.Both failure.


#49

I have been looking into your problem but could not yet think of any causes. Your set up looks correct. Perhaps I will need to run some diagnostics on your computer too find out the problem. It will be helpful for me to know about this issue that might occur to other people as well. Please drop me a private message.


Curved roof
#50

Hi LongNguyen,
Thank you for the very interesting plugin. for some reason the dynashape package never got installed properly on my pc.


Do I miss something ?
Thanks, Ghaith


#51

The files are also empty after installation.


#52

Seems like you downloaded from the package manager. That is an early test version and does NOT work. Please ready my original post on how to install correctly.


#53

Ok. sorry. I thought it might be possible to have it installed through the manager. I was surprised how fast the installation got finished.


#54

Might be worth reminding everyone that you need Mesh Toolkit installed as well or else it does not show up. I actually had this issue for the last few days. :grimacing:


#55

Hi There. giving a try at this awesome work, I have this issue, and can’t figure it out. any clue? thx.

image

Utilities.RectangularGrid reports an internal error, Dereferencing a non-pointer

(why is my image not showing …???)


#56

Good idea. I will update the installer with a reminder message regarding MeshToolkit


#57

Can you please send the file?


#58

it is one of the samples I’ve downloaded. 2_Tensile.dyn

I tried some others, seems Utilities nodes are failing on my machine. Revit 2017.2 and Dynamo 1.3.1


#59

Just to double check. Can you please confirm that your DynaShape version is 0.3.1.3. Can you redownload the installer and install again?


#60

ah no. it is 0.3.1.2. I update now.


#61

no luck either. same result.


#62

Hmm, that’s strange. Can you try plug in a coordinate system into the RectagularGrid node. Maybe the default value does not work


#63

yes, that’s it. With CS, it works just fine.