Dynamo is not available in the current context

For some reason i get this error upon opening scripts:
image

Any advice what to do to make it work again?

Hi,

Do you have an open properties Edit window in Revit ? Or did you open Dynamo in one document and open a second document without closing Dynamo ?

No i don’t/ didnt. i also tried restarting, didnt fix it :frowning:

Are you in a family document or in a project document ? Is Dynamo player closed ?

1 Like

i did set run to automatic and now it works… also when its set back to manual.
strange…
image

1 Like

@Schasfoortyoeri were you working in a perspective view?
I noticed that if you switch from a generic view to a perspective one, Dynamo shows this error.

If you switch to Automatic it works again, and even if you go back to Manual mode it works, at least until you don’t change view again and come back to perspective.
Sounds like a bug, isn’t it?

Here a screencast, sorry for the German (although Revit is in English, it conflicts with German OS) but the red message is the same as reported in the topic:

5 Likes

That might have been the issue yes… i was working in the autodesk sample file, this file opens in a perspective indeed :slight_smile:

Good to know, thanks!