Dynamo exporting PDF by Adobe PDF


I’m trying out the PDF export nodes from the package Archi-lab but I have the following problem. I followed pretty much everything in the article about these nodes from the archilab website. http://archi-lab.net/printing-pdfs-w-dynamo/

In the image below I’ve posted the script.

The script works, as you can see it can read all the 14 sheets of the sheet selection. When I open the PDF it only contains 1 page (the first sheet of the sheet selection).

Someone also got the same problem?

The option “CombinedFile” does not seem to work. It overwrites the same file again and again.
Try with boolean False on “Combinedfile”

Hi Alban,

I’ve already tried but if I do that it prints the PDF’s all seperately. I know it’s possible to combine them afterwards in acrobat itself but this is not really what I’m looking for.


The same question was asked two weeks ago.
You can refer to this thread : https://forum.dynamobim.com/t/archilab-print-pdf-combined-files/18201/3

I dont’t know if somebody find a way to perform the option “CombinedFile”.

Maybe it would be easier to make an other python script that assembles the pdf files from a specific folder.

I am having the same problem. I haven’t found a way to get it to work

To make a python script that merge pdf, you need to install third part library, so it’s not a good solution.

It would be better with a zero touch node and for example “itextsharp.dll” included in a package like in the package DynamoPDF.

1 Like

Hi @DavidV,

I added to the package “GeniusLoci” a node to merge pdf.
You can use it at the end of the print like in the picture :

1 Like

Hi Alban,

My apologies for the late response. Didn’t have much time for working on this graph. In which package can I find the ‘Input.wait’ node and the ‘Views.ToFilePaths’ node?

Also, what is the input for views in the ‘Views.ToFilePaths’ node?


The input.wait node is deprecated.
Replace it with “Passthrough” node from clockwork or a code block with {passthrough,waitfor}[0];

“Views.ToFilePaths” node is now FilenameToFilePaths in Genius Loci package.
The input of this node is a string.

Am I doing something wrong?

You forgot to input the filepaths in the Print PDF node.
You need to input as many printsettings as views. So in you case 4 printsettings.
It’s useful when the formats are differents.

Oh my bad, didn’t notice it. I’ve runned the script and it still prints the sheets separately.

It’s still not good for the number of printsettings.

In the input TargetPDF of the node MergePDF, you need to input a Filepath and not a Filename.
To do this, you can use the FilenameToFilePaths node again.

In the Passthrough node, invert the inputs Passthrough and waitfor.

Hi Alban,

I’ve tried it once more this morning with multiple print settings but it’s still printing the sheet seperately. Is it also possible that the PDF printer which I use, cause this problem? Perhaps you could show an example of your graph which works for you?

So, the printing of sheets works now !
I advise you to connect the sorted list of the SortByKey node to the input Views of the Print PDF node, to always have your lists in the same order.

Add a List.Create after the codeblock “Testboek”.
The node “Filename.ToFilePaths” works only with a list.

You can mark the post as solved if all the workflow works now.


Maybe we’ve misunderstood each other, but it’s not working yet. It’s not merging the sheets PDF together.

If I run the script, it automaticly creates the PDF which are in this list:

But the thing is, those PDF’s are empty (1kb)

When the script is completed, the PDFCreator menu pops out and I still need to save the sheets seperately. Even when I override those 4 PDF’s nothing happens.

You need a single string with a List.Create node + filenametofilepath in input for

The result you want is a single pdf not 4.

Nope, I’ve tried it and it still prints the sheets PDF’s seperately.

You just need to input a filePath in TargetPDF.
You can generate a filepath in many ways so don’t focus on it and use the OOTB node FilePath.