Dynamo - Excel macro problem?

Hi, I made nodes to export data to excel and it worked well. But now something has happened in my Excel and now it just makes empty sheet in Excel. I have restriction to use developer function in Excel either. Because this laptop is office’s one, so I can’t change any properties of .exe file without any permission. Is there any way to recover this problem? I tried via Excel.ExportAs File node(Crumple) but this one shows same result.

there is nothing related exporting to Excel from dynamo to Excel macro, lets think of something else
have you tried make the override true ?

Hi @khuzaimah.ElecEng
Yes, I did before. Is that causing this problem?

it may yes, other than that i am thinking if the excel is protected , that cant be modified

if excel is possible to be modified then what can I do?

is the excel ext. is xlsm ?

It’s xlsm, I added macro in the excel file and tried to get inputs through Dynamo.

I reinstalled the Ms 365 including Excel, And now it seems like there isn’t any problem in Excel but still can’t export data from Dynamo,Do you have any idea? Should I reinstall the Revit also?