Dynamo Crash 'Manage Node and Package Paths' ?! :-S


Dynamo (2.0.2) and Revit (2018) keep crashing when I add packages with ‘Manage Node and Package Paths’
Settings -> Manage Node and Package Paths -> (Select Folder)

Testing on two different computers, I have tried to regroup the packages into subfolders and adding them one by one and them removing the crashing package. When I bundle the packages into a single folder and try again Revit and Dynamo crashes. -.-*

Here’s the initial list of packages I’m trying to add:

Clockwork for Dynamo 2.x
Duct Tape
spring nodes

Does anyone have any suggestion what to do?

Confirm all packages were originally written for 2.x. Check the file format (json vs xml) as a starting point.


Try also to add one package at the time to see which package fails…

You should also verify that you dont have more paths than expected. Example do I have all packages dedicated to Dynamo 2.0 in one folder and all non-dedicated packages (for 1.3 and 2.0) in a “common” folder.


Hi Jacob and Erik,

Thanks for the quick replies.

I didn’t check the format (jsom/xml) though I specific looked out for 2.x so that should have done the trick I guess. I also tried to ad packages one by one on two different computers in parallel…

I found a solution earlier, just before I went out the door, sorry for not posting it:
- Close Revit and Dynamo and changed paths in the DynamoSettings.xml file manually.
- Reopen Revit and Dynamo and now it just works :slight_smile:
(note you can create a generic xml file with /%username%/)

I have no idea why I can’t use the UI to add the path without Dynamo and Revit crashing. :blush:
After the crash, Dynamo would have the old paths again.
Maybe Dynamo just became overwhelmed #tooManyNodes :stuck_out_tongue:

Editing the XML file manually should not play any role… if it does that, then I think it is a completely other problem.

I worked on two different computers that otherwise crashed loading the packages using the UI. :smile:

This method doesn’t for an update to the nodes inside the packages while the UI is open (you’re not forcing an update of nested nodes). You may have missing or broken nodes this way, but I haven’t been able to reproduce so I cannot say. Best to confirm they’re all 2.x compliant first by checking the format.

I have been running into a very similar issue. I have found that I can open and close dynamo normally after I have deleted the dynamosettings.xml file. Slightly differently though, I can add the custom nodes and package paths when I open it the first time and it will run properly, but if ever I close and reopen Dynamo as second time with these custom packages loaded Dynamo is more or less unresponsive and once I close Dynamo the second time for some reason it completely crashes both Revit and Dynamo with a “Fatal Error” message. No clue what is going on with Dynamo. I am using Dynamo 2.3 and Revit 2020.2.2