Dynamo and Revit

Guys, I have a problem running Dynamo inside revit. Does anyone know how to solve? I’ve done everything possible. I uninstalled Dynamo, delete folders and nothing. Help me please!

Welcome to the community…can you post Revit version and Dynamo version

Revit 2020.2 and Dynamo 2.5.2

In Dynamo they had two versions, 2.7 and 2.5.2. But I took both. I think I took

Hope it will help you


Hy @gustavomateus007,

I had this issue in the past. I can’t remember how I solved it. I guess by reinstalling dynamo Core.
Check this link, it says in the last reply that reinstalling worked.


I had the same or similar error.
The Problem was an addional plugin /addon called relux. I would dissable all plugins and try if this solved it.

Do the following to disable add-ins :

  1. Close Revit .
  2. Locate the following folder: C:\ProgramData\Autodesk\ Revit \ Addins [Version].
  3. Temporarily move the add-in files from the folder above to another location.
  4. Launch Revit . Add-ins will be disabled