DynaMaps push the location to Dynamo

Hello,
I’m following this guide here: https://data-shapes.io/2019/06/07/getting-all-site-geometry-inside-dynamo-with-dynamaps/
Where I’m trying to get the map and the whole topography as the guy in those steps, but when it comes already to step number to, where you need to select node you want and then “push to dynamo”, I’m getting this error here: Warning: Internal error, please report: Dereferencing a non-pointer.

Does anyone know maybe where I’m doing mistake, or if I need to do something else?

Thanks in advance for helping me out.

Hi Pete,

Could you post a screenshot of the issue? I have found that selecting “Push to Dynamo!” first and then loading my nodes in works pretty well. Also, are you running Dynamo in Manual run or Automatic run?

Hi!
Yes, I can. Here is the screenshot:

I am doing exactly the same, first I choose the location, then I click take me there, it shows nicely where is the location with that “google pointer” and then I put node on work plane and I press push to dynamo and this happens. Also as you can see on screen shot I’m doing it in manual mode as recommended in manual.

Try pushing to Dynamo before placing the node.

I’m getting the same error.

Hey,

I think this is caused when the attempt to create surfaces from the ‘building’ polygons fails… Perhaps because the polygons are not closed or create a shape which cannot be resolved.

Try pulling in just the polygons and see if that’s ok? Then you can try to manually create the surfaces… I presume you’ll actually be more interested in solids, so I’d use extrude to solid rather than patching first…

Hope that helps,

Mark

Hey Mark,
I’ve tried to pull just the polygons, but I got the same error…I really don’t understand where the problem can be.

I was thinking, can the problem be in Dynamo? Because I am using DynamoSandbox, but there is also Dynamo in Revit as a plugin, but I tried both and I’m getting same errors all the time. Also in Dynamo in revit I can’t use DynaMaps for choosing location, that only work in DynamoSandbox for me, which is strange too.

Maybe could you post your files?

If you try a different map at a larger scale does it give the same message?

I had to change my working range to extra large, perhaps that helps?

Otherwise, perhaps @Mostafa_El_Ayoubi would be ok to comment on whether it’s a Dynamo issue or not?

Thanks,

Mark

Hi! Thanks @Mark.Ackerley for notifying me :slight_smile:
@pete288x can you please share the location your trying to work with? Maybe try a different location? It is possible that there is no osm data in your region…

Hi Mostafa,
Yes, this is the location: Sandkaj 19-15, 2150 Nordhavn

I’ll try to use a different location and see if it works.

Very strange, it seems to be working fine here. What versions of dynamo / revit and what language are you working in ?

1 Like

Hm, that is very strange indeed. I’m using Revit 2019 in English and Dynamo Sandbox the latest version also in English.

Do you need to set up location or something in Revit, or do you need to have a Revit open in general? Sorry for maybe all those stupid questions, but I’m kind of new to it all.

DynaMaps only works with Dynamo Revit because there are some calls to the api (mostly unit conversions to fit project settings). That might be the reason!

Ah ok, but then when I open my Dynamo Revit and install DynaMaps to it I can’t see in “View tab” DynaMaps options to put address there…

Is it Dynamo Revit 2.0.x?

I’m actually looking into it right now and it is not. It’s Dynamo Revit 1.3.4.6666, but it says it’s up to date.

Here is the screenshot: DynamoVersion

Okay now it all makes sens :slight_smile:
It probably says up to date because it’s the latest build of dynamo 1.3.
But for DynaMaps (and many other packages, especially those using zero touch or nodemodel) you’ll need to upgrade to dynamo 2. The latest release is 2.0.3. But this is a major update! Some of your dyn files may need adjustments etc.
Please let me know how it goes!

1 Like

Ok, it actually showed me the available update now in Dynamo, but after restarting Revit I’ve checked again and it’s the same “old” version again…

I will try to work on this update and see how it goes and I will try to get back to you if it works, or no.
Thanks a lot for helping me out with my problem!

No problem! You can get the most recent stable build here :
https://dynamobuilds.com/

1 Like