Dimension By Element in Plan View on Different Z for start / end

Hello everyone,

Currently, I am trying to create a dimension based on two adaptive points (family attached: “measurement points”). I’m using the DimensionByRefernces node from the Geniusloci package (test script is attached).

(video in the comments)

  1. I’m placing a dimension based on two adaptive components by hand. It then gives me the “correct” value which is 23624mm
  2. Secondly, I’m doing the same step with Dynamo with the Dimensions By Reference Point. Reference Type is center-to-center and the family instances are the adaptive points
  3. If I run this the output seems to be the same 23624mm, but if I look closer with the Dimensions.GetCurve (Rhythm) node and compare this with the Line between the points of the family instance and the line input for the line for Dimension by Reference you’ll see that every start point / end point / vectors and line length is slightly different.
  4. If I run the same script but placing the dimensions a little bit more to the left you’ll see the dimension value is 23623mm.

I have tried to recreate this error outside of this project and I noticed the problem only occurs when the points are on different Z-values. If I run the script (without deleting the Z-values for the line) it gives me the following error:


If I delete the “z-values” for the of the points for the “line” input of the DimensionWithReference node the dimension is created, but slightly inaccurate with the manual dimensioning.

DimensionByReference.dyn (28.7 KB) MeasurementPoint.rfa (324 KB)

I hope someone can help me. If you need more info, please let me know.

1 Like