Deleting/Renaming Fill pattern element "Solid fill"

Dear Dynamo Users,

I have been struggling to omit unnecessary fill patterns which aren’t used in my template.
When I reformed my template, for some reasons I got a bunch of built-in fill pattern "Solid fill” and some Japanese version "塗り潰し”.

I used Dynamo to delete those below but it turned out as other fills are only deleted.

What I next tried was changing the name of the fill " Solid fill" to something like A fill so I might be able to delete by tricking that is no longer system fill pattern, as I know Solid fill won’t be deleted in Revit.

I tested the node then realized even it seems that the name of fill pattern was changed but when I get back to my template there is nothing has been changed.

What am I missing?

It is very simple nodes but fill-pattern element seem to stay somewhere deep.
FillpatternElement
Fill%20Patterns

If you give me any clues, it would be appreciated.

Yuki

I believe that this fill pattern is hard coded into Revit, and that deleting it would corrupt your models in an undesirable way.

It doesn’t matter if I corrupt the model for now because I am amending not a model but a template.

The name for fill pattern itself is set by users but solid fill is by system that is tricky.
For some reasons, my template got a lot of solid fill and now I am trying to delete.

I deleted material, fill regions but still those solid fill only remained.

I might finally just redo template but I am hoping to find culprits for this problem.

Thank you for your comment though.

Yuki

The fill pattern with the name in the English Language version, which is element ID 20 by default in the default Revit 2019 template, cannot be deleted without causing a non-recoverable corruption in the database. It also cannot be renamed, adjusted, or edited in any way which I am aware of. This is one of those elements that has to be in your model, as everything else is built atop it. Note that in your first image when you highlight the first drafting fill pattern in the normal Revit UI you get no option to edit, delete, or duplicate it. You just can’t remove this one.

The fact that you’re planning on saving this as a template is irrelevant, as a corrupted template won’t allow you to create a non-corrupted Revit project from it. If it even let you start a project with it, it would just be a matter of time until your model went belly up and you lost work and/or productivity while the database is repaired.

That said, you do appear to have additional solid fill patterns. These should be able to be deleted. My guess is you need to wire the All Elements of Type node into the Elements.Delete node directly. This will get rid of all but one of the solid fill patterns. If that doesn’t work, post your .rte and I’ll have a look at building a graph that removes them.

My biggest problem is I have no idea how I got those amount of system fill patterns.

As you said I already did select Element type=FillPatternElement and directly wired all elements of type, then connected delete node. Only solid fills remained.

Here is the file but for security reasons, I also deleted most of setting for my template.
You will still see the problem.

SolidFillIssue.rvt (1.3 MB)

Thank you,

Yuki

Any update here?
I have the same issue. Duplicating of solid fill patterns.
I always noticed the duplicate solid fill from different language template (Solid fill, Riempimento solido (ITA) etc.), but in this case solid patterns are still multplicating 1, 2, 4 times…coming from .rfa files I guess.
This happend when I renamed the original Solid fill as “RVT_Solid Fill” (always by Dynamo), but after that I could not deleting anymore.

2018-11-20%2015_56_45-Fill%20Patterns|690x395

“Solid Fill” pattern cannot be renamed/deleted, according to the Revit API documentation. However, that’s only the case for that single Fill Pattern.

I am not sure why is that, but that’s what the documentation says. I am guessing it’s because there has to be at least one Fill Pattern in the document, and “Solid Fill” has been chosen for that. However, all other Fill Patterns can be renamed like so:

Now you can also try and select all/any non “Solid Fill” patterns and delete them like so:

One thing to keep in mind, is that you might see multiple matching names in that list. That’s because Fill Pattern can be Drafting or Modeling, and there is for example Wood 1 Fill Pattern for Drafting and Wood 1 Fill Pattern for Modelling. The difference between these is that Model Fill Patterns stay true to their scale, and will become bigger/smaller as the view scale changes, while Drafting Fill Pattern, doesn’t have scale, and will show at the size that it’s drawn/defined. I think I got that right. Anyways you can check if Fill Pattern is Drafting or Modeling like so:

Cheers!

Hi All,

I had a similar issue with models created with revit set to different language. We were using these models from consultants as link and suddenly the phase filter overrides using the solid fill hatch pattern were not working anymore (linked elements were showing without pattern…). I troubleshooted the issue as in one model the fill pattern was called “Uni”(french revit version) and in our model it was called “Solid fill” (English revit version). When testing the overrides using another custom hatch, the link was diplayed properly by the phase filter.

Jumping now to the topic of this discussion. Unlike what is written above I did manage to rename the solid fill “Uni” to “Solid fill” using the script below. (in this example renamed as “Test”)

RenameFillPattern2

So renaming the french “Uni” hatch pattern to “Solid fill” did the trick.
Of course I can not guarantee that the model is not more likely to get corrupted. So far so good it does save, and react properly. So for now this resolved our issue regarding linked model not reacting properly with the phase filter wich is all we asked for. I will keep track and give any update if the model will show some sign of corruption on the long go.

I also had some other file with multiple solid hatch pattern coming from different language. In this case I did not manage to delete the duplicates… To be continued !

Regards