Delete Line Styles

Hi all,
I am trying to delete unwanted line styles from a project. The script seems to work fine but the line styles are still there.

Please find attached a few images to explain better my issue. The lines I am trying to delete are called TEST. After running the script there is no Line Weight assigned, neither color or pattern. It’s not even possible to select them from the drop-down menu, when trying to amend a line. The problem is they are still in the list.

Any idea?

Thank you in advance.


This worked for me:

However if you want to delete additional styles after the first time, you might need to close and reopen Dynamo.

Remember, you CANNOT delete the pre built system line styles. The will “disappear” if you delete them, but will show back up the next time you open. Been there and tried it. Quite frustrating, but it that what it is.

It didn’t work for me. I got a warning saying “one or more of the input types are not marching. Couldn’t find a version of Delete that takes arguments of type (Revit.Elements.Category)”.

I am not using the latest version of Dynamo, not sure if that is the problem; I am using 1.3.3.

It might be that it doesn’t work with previous versions of Dynamo and/or Archilab.
If you have the chance, try to update both of them. At the moment I cannot test it with previous versions, sorry

Can you post a new picture and the graph you are using. Please make sure the results windows are open on the image so we can see what you are sending / getting.

Here is another option, using bymorph nodes and springs. This has come in handy, once a project had so many exploded line styles that opening the detail line drop down took about 30 seconds. no good.

Thanks all for the replies!

I tried what you sent me and it seemed to work, but same as happened with my graph, the line styles are not in the drop-down menu but are still in the list of line styles and in the visibility/graphic of the views. By any chance, do you have the same?

this will help clear out those


Thanks they are finally gone from the project!