DanEdu - no output / 'failed'


#1

Hi all, @erfajo,

Now my holiday is over, I’m picking things up where I left them. I see that your package has been updated. So I updated my dynamo script too.

I noticed that the Rhtyhm application.CloseDocument errors. ‘Warning. Operation Application.CloseDocument failed’.
Putting a watch on DanEDU.FamilyDocument.AddSharedParameter log output results in ‘null’. (So I assume that’s why the Rhithm node isn’t working)
The input is good: Autodesk.revit.DB.Document list.

Revit 2017.2
Dynamo 1.3.1
DanEDU 2017.802.1
Rhythm 2017.8.15

Any thoughts?


#2

It is hard to tell what can be failing, I need some more informations to work with.
Please attach the needed files for checking errors. The needed files would be, first, a screen dump showing where errors occur, add watch nodes for output where steps seams to fail. Next, attach the family (1-3 files) and the shared parameter file.


#3

Hi @erfajo,
I have the same problem. I can’t even get the .rfa file from DanEDU.Directory.ContentsAll node

image
image

I’m using rac_advanced_sample_project file. I’m trying to add shared parameter to door family.
Revit 2017.2
Dynamo 1.3.1
DanEDU Dynamo 2017.901.0

Thanks in advance.


#4

I have tested the nodes in the below graph… and it worked as expected.
Try to upload your graph (as a .dyn file) and let me test it…

Postscript:
The Directory.ContentsAll node is updated as shown below


#5

Thanks for your reply !
AddSharedParameter.dyn (7.8 KB)
It’s my dyn file.
The family I want to add shared parameter is in the default folder.
C:\ProgramData\Autodesk\RVT 2017\Libraries\US Metric\Doors


#6

Your graph looks correct.

However, I did try to provoke my own graph that looks very much like yours (I have shared that in another post dont remember which). If I somehow run the graph and it goes successful, then I change something (like the input to ‘AddSharedParameter’) and try to run it again, then I get the same error with ‘CloseDocument’. Result is that my dynamo session crashes and I have to restart Revit. I hope that @john_pierson can answer that problem.

Your problem starts however, at your reading the directory. Those files are placed in folders by the Revit installation and are most likely “write protected”, mine is… and then I get the same reading error as you. Remove their write protection and you are back in business.

If none of this helps you, then please provide your “shared parameter” file, just to verify you dont have any issues in that file.


#7

Thank you so much,
it works. Because the files in default folder are protected by the Revit installation, just need to turn off the Read-only option.


#8

Working with background opened files in Dynamo is definitely a bit unstable and unpredictable as Dynamo is trying to swap documents constantly… Unfortunately I do not have a straight forward answer for this.

Although it does seem the read only factor plays into this error quite a bit!


#9

Lets hope that everything will be more stable in dynamo 2.0 :slight_smile:


#10

@erfajo Is there an easy fix to modify the Python to run this node on a single, open RFA instead of a group of RFAs within a folder structure?

We’re looking for something like this, that we could use to batch apply multiple shared parameters since it takes so many mouse clicks the old fashioned way.


#11

Please use the right data input
Capture
se this example -> DanEdu - no output / 'failed'


#12

Hi @nickroz,

I have done an attempt to help in the below topic.

https://forum.dynamobim.com/t/nested-families-and-adding-parameters/15777/7

I couldn’t get the OOTB node “Document.Current” to work as you suggested above.
The custom node of the “Archi-lab_Grimshaw” package “Current Document” gave better results (not always stable).
I hope it can be of help.

Kind regards,
Mark


#13

Thanks for the tip off.

I was getting the same error message, in my case there was a typo in one of the shared parameter in Revit.