Current Document returns null

Out of nowhere Current Document from archi-lab as started returning null. Any ideas what could be causing this?

Which arch-lab version your using? Possible to share screenshot.

1 Like

EDIT: Ok so I don’t think it’s breaking when I connect it to anything other than a watch node I’ve recreated a small portion of the script and it is working. There must be something in the main script that is causing this then.

I’ve tried to use orchid as well. I don’t think the built-in node will work because it has a different result. As soon as I attach the nodes to anything other than a watch node they start returning null. The weird thing is that this node was working fine for a week with this script as I was working on it and then out of nowhere it stopped. I’ve updated Archi-Lab today to see if it would help but nothing changed.

Script Name: Revit Dev - Family - Nest Face to Unhosted.dyn

Packages used in this script:
Orchid version:
Genius Loci version: 2019.9.26
Clockwork for Dynamo 2.x version: 2.1.2

TimeStamp : 2019/12/27 10:2

For some reason data shapes isn’t noticing that Archi-lab is used in the script. Here is it’s version:

I think I found the culprit. The nodes don’t seem to like these chunks of nodes:

Once I took this out the nodes started sending the current document again.

This occurs about 90 percent thru the script. The issue is sometimes I have families that have no formulas and the orchid node doesn’t like getting empty lists as you can see. So I tried replacing the empty lists with a parameter we don’t use and a blank formula.