CreateElevationByMarkerIndex not working as expected

Hi All,
I have again the same issue with tools stop working properly when something has to be done earlier. After I create the floor plan views I want to add the elevations but the tool show the warning of the picture which I suspect it is due to the views are not processed when the tool try to add the elevation marker. No matter I have added a transaction start and transaction end before the process expecting the views are processed first. I suspect Dynamo do not do that it process the node when the views are not created yet.

I have no idea how to manage to get Dynamo wait the views are ready and later do that process.

Thank you in advance.

I have tried Passthrough but I still have the same result.

On your elevation marker how many check boxes do you have if you select it?

1 Like

That was the problem. I did not realise someone changed the family for “one way one” so it is impossible to select the other markers. Sorry, I did not realised before.
So this is resolved.


No worries! Glad you got it worked out! :raised_hands:

1 Like