Create Shared Parameter Node - Unstable?

I know there’s been quite a few posts tackling this topic but I couldn’t find an answer to what I was looking for.

What I am trying to do is simple: create bunch of shared and project parameters using data from an excel sheet and it seems I am succeeding at it, but every other time I get this error:

The referenced object is not valid, possibly because it has been deleted from the database, or its creation was undone.

And when I say every other time I mean it literally. I execute the script and I get an error (missing project parameters) then I change couple of parameter names in the excel file and it works fine (no errors, no missing parameters).

Does anyone have an idea what’S going on/ what I am doing wrong?

PW_paramsTest.xlsx (17.0 KB)
createSharedParametersFromExcelSheet_V037.dyn (23.8 KB)

I guess it has to be some kind of a bug, because the behaviour is more or less predictable (as far as i was able to figure out until now):

  1. i run it with generic parameter names (that are easy to track and delete later) and sometimes it gives me an error, sometimes not
  2. i run it for the second and third and any number of times with correct parameter names and it does what I expect it to do without any errors

anyone interested in fixing it? :slight_smile:

Can this help you?
https://forum.dynamobim.com/t/orchid-package-released-at-github/22671/10