Create Annotation Tag - Room is not iterable error

rooms

#1

Hey guys!

I seam to have a problem with the Create Annotation Tag node. I want to put multitle room tags, on multiple views with multiple rooms visible. I think I got the inputs right, the views appear as many times as there are rooms I want to tag on them, the points are given by the exact same rooms, and a “Room is not iterable” error appears. What am I doing wrong?


#2

I think it’s a list @ level problem. I’ve never found much of a use for @L1, myself. Try switching that off - I imagine that node is able to handle multiple lists of elements as inputs


#3

Well I do quite od bit of level juggling, so I sometimes find some use for @L1. In this case I tried multiple levels, and modifications of lists. but nothing seems to work. Eliminating the list level, flattening both lists after that, changing both to level 2, nothing seems to work. I constantly get the same error.

A little update. I’ve chopped the point list (the one that goes into TagLocations), so now I’ve got all the lists with an identical structure. Now, when I give all the inputs L1, the same error appears,(room not iterable), and gives a correct number of elements (282). But when I turn levels off, or use L2, it gives a different error (There is no tag available), and gives an icorrect number of elements (60, which is the number of sublists)