Corrupt dynamo file?


#1

Hello guys, today, dynamo wouldn’t respond so I closed it after attempting to save a dynamo file that was running. (for too long) Then, I tried to open it back up and it just came up with my nodes as little blank blue boxes with wires connecting them, and the cursor wouldn’t stop spinning. So I closed the Revit process tree in Task manager, and then restarted Revit and dynamo. Now, the file wont open at all its been “thinking” for 20 minutes and the cursor just still keeps spinning. Did I inadvertently corrupt this file? Is there anyway to recover it? Or should I just “wait it out”? Thanks, in advance. The file is attached. Fixer - Copy.dyn (583.5 KB)


#2

This has also happen to me once… do have copies of your work in progress. I am affraid you need to remake the graph.


#3

@mix, I tried opening the graph in Notepad++ and changing the HasRunWithoutCrash option to true. This allowed the graph to open after a few moments on my end.

@erfajo has an excellent point regarding backing up your work. I also wanted to provide additional advice, you might want to consider cleaning this graph up and segmenting the workflow a bit. Upon opening I have no idea where the graph starts or what most of it is doing.

*******NOTE: I Cannot guarantee that the following file will open for you. If it does not work, you will have to resort to rebuilding the file as @erfajo pointed out.

Fixer.dyn (575.7 KB)


#4

I moved the solution mark to @john_pierson :slight_smile:
My answer is more an advice than a solution. My working method is to keep critical stages of my files, to prevent this error to occur :slight_smile:


#5

…I thought I made complicated graphs…