Column on wrong level (StructuralFraming.ColumnByCurve)

archi-lab

#1

I want my column on level 1 but it is located on level 0. How do I get the column to the right level?


#2

Hi @s163803,

Your curve must be in the correct ‘Z’ coordinates. Right now you are say the first point ‘X’ is located at datum 0 (Z=0), The top of the column is 1000 from 0 (Z=100).

You have assassinated the column at level 1 but the column top and bottom can be place anywhere along the Z axis relative to Z=0

You will need to adjust your ‘Z’ coordinate as follows:
x = (0,0,5000)
y = (5000,0,6000)

Hope this Helps.


#3

Hi @cescobido

It works but… what does the Level option even do then?
It seems like the model does not change though another level is picked.


#4

It does exactly what it say, it is the association only for the Column