Code Block Bug?


#1

I’m trying to call other nodes in a code block, but it seems that any time I try this I get the same error “Dereferncing a non-pointer.” I figured I was doing something wrong, so I opened the training file on code blocks thinking that file must work, but I get the same error messages in that file as well. Is this a bug in code blocks? The attached image is from the training file I download from the site.

Code Block Error

 


#2

We have a current issue being addressed that namespaces can get mixed up. That is–if you have something like Rhynamo installed, then there is more than one “Point” class–one from the geometry library and one from Rhynamo, so the Code Block can’t execute. Until a solution is implemented, you might have to uninstall Rhynamo or other packages that use loaded libraries if you would like to use code blocks.


#3

Thanks Colin


#4

if you have rhynamo or similar installed you have to use the full name of build in functions.rhynamo

not a solution but a workaround: