CivilConnection nodes not working

Hi everyone,

I’m trying to use the Dynamo CivilConnection package, but for some reason the nodes are not working:

I’m using Revit 2019.2, Civil 3D 2019 and Dynamo 2.0.3. I installed the package CivilConnection2019 following the Linear Structutes Workflow Guide, but even the first node to make the connection with Civil 3D (CivilApplication.CivilApplication) does not work.

Any idea what the reason could be?

Thanks in advance!

FYI @Paolo_Emilio_Serra1

@dair can you tell us what the warning from the CivilApplication.CivilApplication node is?

@dair can you try 4.0.1? Apologies I made a mistake when compiling 4.0.0 that prevented CivilApplication to work.

1 Like

Thanks, @Paolo_Emilio_Serra1 and @JacobSmall !

I downloaded the 4.0.1 version and now it is working :slight_smile:

@Paolo_Emilio_Serra1, @JacobSmall,

First time working with CivilConnection and having similar issues as described above. I run Autodesk Revit 2020.2.2, Civil 3D 2020.4 and Dynamo 2.2.0.5885. I have installed the latest version of CivilConnection2020 (5.0.0).

Am I missing something? Both Revit and Civil 3D is open. Please help?

Thanks!

@Paolo_Emilio_Serra1, @JacobSmall,

Not sure what the issues was, did a good old restart and all is working now…

Cheers

1 Like

Hi everyone,

I’ve the same issue with Revit 2021.1.1 and Civil 3D 2021. I installed the package CivilConnection2020 version 5.0.4.

Thanks

Hi. The same for my side. I was using my Dynamo script succesfully with Revit and Civil 2020, and now when I switched to 2021 (CivilConnection version 5.0.4). The very first node doesn’t work:

What can I do about it?
Btw. I am working on a Virtual Machine (Microsoft Azure), if that could be important. I checked also version 4.0.4. Doesn’t work also - the same error with CivilApplication.CivilApplication - Warning: CivilApplication…ctor operation failed.
Object reference not set to an instance of an object…