Civil Connection Application node not working

Usually i have an idea of what the issue bug might be with nodes but this one i doing have an answer or a work around.

I have both Civil 3D 2020 and Revit Open with both files saved and both in Meters but i am getting this msg when i try and connect the two using this node from the Civil Connection Package.
Warning: CivilApplication…ctor operation failed

image

Civil connection works from dynamo revit instance not from dynamo in civil 3d or from dynamo sandbox.

You will need civil connection 2020 version to work with civil 3d 2020.

That’s what’s make the issue more confusing as that how i have it setup. Everything is 2020 on this machine. And the Civil Connection package is only running in Dynamo in Revit. As the Package does not work in Dynamo for Civil 3D, which makes sense.

@Matt_Gaydon I assume you checked the user guide and your environment is set to Civil 3D and not, for example, 3D modelling. Can you confirm both my assumptions?

Sorry for the delayed reply was out of the office till today. Yes had read the user guidelines and as i had just drawn and saved an alignment curve in Civil i knew i was in the right environment.

Just tried again this morning and found it works in with a Revit Project file but fails and gives the same error as posted above if your in a Revit family file. All files are set to meters also.

Don’t know if this is a bug or is it only designed to work in Revit project files?

CivilConnection does not work in Family files as they don’t have the Total Transform.

Ah ok, good to know. Don’t see any issues yet with just working in the Project File, will shout if i have any issues. Also just looked up Total Transform in the API and that makes sense too.

Good to hear, thanks!