Change Spot Coordinate Types

I’m trying to change a Spot Coordinate Type to a different type, but I cannot override it. Element.Set Parameter says the Type Name is read-only. Anyone have luck with this? I know Spot Coordinates are different than Dimensions, but they are still reading as Dimension Types. Using clockwork with spot coordinate.bypoint.

Thank you in advance,


You need to change the “Type Name” for the ParameterName to “Type” and then you have to make sure you are setting it with another “Type” (green highlighted number) and not a string. I would take out the FamilyType.Name node and see if that also helps because it is giving you are “string” value that doesn’t mean anything to the node. You can see that it wants a “dimensionType” for the input, but the output of the FamilyType.Name node is “string”. It helps a lot to check the input / output names of the nodes as they will tell you what they are looking for to work.

I have tried changing the parameter name to Type and it says no parameter found by that name. I have also tried by making the value as another Dimension type, but it still doesnt change the element. The Spot Coordinates are very odd since they are labeled as system families. Try it yourself and you’ll see.