Change room level after placement

I think this will be a no - but just to check if you clever people have a wonder solution.

I have tried to change the level of a room after placement as it has gone in on the wrong level. The parameter is grayed out in the properties palette and dynamo says “this parameter is read only” when running the script below.

Any other opportunity here ?

Thanks,

Had the same issue about a year ago. Solution for me was to cut/paste the room to a new location.

2 Likes

This looks like a similar issue I was having yesterday, i think it was where the parameter “Level” is defined twice within the family as built in parameters. ASSOCIATED_LEVEL_PARAM and LEVEL_PARAM from memory, but don’t quote me on that. It worked 50% of the time for me using the set.built-in.parameter node from #archi-lab worth a shot if nothing else

1 Like

I haven’t tried this with Dynamo, but an old hack regarding changing levels of placed rooms, is to group the room/rooms. This opens the otherwise read-only level parameter.

I guess the workflow would be something like:

Get Rooms at said level -> Group them -> (End transaction perhaps?) -> Set Level param -> dissolve groups.

But as I said, I haven’t tested this myself :slight_smile:

2 Likes

Thanks all.

Didn’t want to cut/paste as the MEP might have the grump as they are using the rooms to create spaces. I did see what Ewan said, but hadn’t got it to work.

However, the grouping works perfectly - well happy with that solution.

Cheers.

I might go and revise my script if grouping is a go-er :slight_smile:

Once the desired elements are filtered - how do I group them ?

There is a Group.FromElements node in Clockwork (and optionally, a Group.UngroupElements in Rhythm)

I did try that - see below. No group gets created ?!

This node is awaiting for elements as an input. This page could help if needed:
http://dynamoprimer.com/en/03_Anatomy-of-a-Dynamo-Definition/3-1_dynamo_nodes.html

1 Like

I see, I am feeding in a list instead of actual elements. I think I am sorted now, thanks.

Working… it only needs the correct parameter’s name.


Needs
Clockwork for Dynamo
Archi-lab_Grimshaw

“Referencebene”? shoudn’t that be “Level”?

:slight_smile: