Change dimension style

hi

how can i change the linear dimension style of a lot of dimension in the drawing by dynamo?

i can’t use the change family type node from archi lab because it won’t work in dynamo 1.2.1
i tried several things
the image is the most recent attempt

See this (Dimension.SetType is from Clockwork):

Thanks Yna

but i stil get a empty list by succes
also when i use all elements of category

could it have something to do with my other problem:
Notification : System.IO.FileLoadException
see my other post

i uninstalled prorubim
Dimension set type stil gets the same result

Look carefully at the dimension type style: you can’t change a style to another, this could be why…

the selected dimension and the selected type are both linear dimension style
Dimension Change dimension style.dyn (10.0 KB)

here is the file

It should work. The IN[2] item could be an inappropriate choice: try to use one with a specific name that you set by yourself, so that you can recognize it…

yep solved
youre right
a lot off thanks

There is no need to use Clockwork as this can be done with OOTB (out of the box) nodes like so. Again, pay attention to Dimension Type selected as it has to match the type that you are trying to replace. You can’t take an angular dimension and replace it with linear type.

EDIT:

To check dimension type style just use python like this:

#Assign your output to the OUT variable.
OUT = [UnwrapElement(x).StyleType for x in IN[0]]
1 Like

Thanks Konrad
due to you guys i am learning fast

When searching the output of the Python Script, I can not perform a “Indexof” or a List.ContainsItem". Why? It looks like a list but the values seem to be unreadable… Thoughts? Thanks for the help

“String From Object” My Bad…

@ Konrad
I have followed your script but I get the error.

Thanks for your time to reply, however, it does not change all of one type to another.

Instead of the Element.Name node
Use the Element.Name+ node from clockwork package
or
the node: string from object

Thanks for your time.

I tried both your recommendations but to no avail. I want to change all instances of a dimension type to another type. Something is missing.
I assumed the process would follow:

  1. Select an element
  2. Select a type
  3. select all types
  4. Change type to another

I don’t see a select all types in that. Am i wrong?? I always try to get my head around something even if I am way off.

Dimension set type is from clockwork package

Thank you. It is kind of working, but it is not selecting all of that type. The select model elements node allows me to select the element, but there are 100’s of that type i want to change.
The reason why I can not just select a type and select all instances in project, there are some groups across multiple views, so it does not allow me to select them all just change the type.