Center to center dimension of linked elements

Hi all,

I am trying to generate dimension for the linked elements by selecting the element node with reference to the line. I am getting this error. Please help me out the solution for the error. (in the select model element, I have selected the model line drawn. Detail line marking

Hello @shashank.baganeACM ,

I am not sure, but can you try to convert link element to elements from this node and check
or change the lacing from auto to longest

@honeyjain619 I have used the node but I am still getting the same error like “Invalid number of references”

Can you please tell me why I am getting this error ?

@honeyjain619 I have modified my graph slightly but still I am not able get the dimension. Can you please help me out for this ?

@shashank.baganeACM ,
can you please share both .rvt and this .dyn file for the reference.
So i will try my best to help you in this case.


What package does the Dimension.Create node come from?
Use instead the Dimension ByReferences and Convert Linked Reference nodes.

Hi @Alban_de_Chasteigner you can find Dimension.Create node from Archilab package.

If I use this Dimension Byreferences and Convert Linked reference nodes still I will get the same error or warning. Can you please tell me how can I resolve my issue ?


Show the graph and the error content please.

I can share only the dynamo file and it is not possible to share the main project file. and I am trying to generate dimensions between two plumbing fixtures which are in the linked model loaded into main project.

Automate dimension for linked elements.dyn (33.8 KB)

It is working fine if you stick with the Genius Loci package and collect the correct reference Planes :

Yes @Alban_de_Chasteigner but if I try to give a dimension then my output is showing null

Remove the uneccessary @L2 on the FamilyInstance Reference ByType node.
Your input references is a list of list and should be a list.

1 Like

Hi @Alban_de_Chasteigner

I am getting dimension as output but if you see the inputs in graph, everything shows null n]values but it is giving me output. May I know the reason for this ? I am bit confused and to get the output successfully, I have to run the script twice, then only it gives dimension.

So I just wanted to know why I ma facing such weird behavior of script ?


That’s weird. You need to restart Revit and Dynamo, this is not normal behavior.