Carriage Return (aka Line Break, aka Enter)


I am trying to remove a carriage return from some text and I am finding some odd behavior. Do any of you know what might be going on here?

This is actually what I am trying to split but as you can see neither of the two methods from above are working. The text is coming from a Text Note in Revit (the file is in Spanish. I not sure if a Spanish keyboard has a different enter or not).

Revit 2019

Thank you,

I know that how to get a multi-line text i can use /n

That is what I thought too but it is not working. I then went to my sample (the first picture) and found that different types of text formats give different results.

I will keep digging though.

I just removed all characters except for the return and that works but I am not sure what it is.

After isolating it, I used Clipboard.SendTo from clockworks and then pasted it into the String node and it is working.

Still not sure what it is but it responds very strangely in my sample from the first post.

1 Like

Here is the character

If you copy the element between the lines separating the ///// you should be able to get it if you want to take a look yourself.


That did not work so here is a dyn with it in a sting.
Carriage Return.dyn (1.7 KB)

It’s β€œ\n”.

A full return is β€œ\r”.

1 Like

Thank Kimberline,

I had tried β€œ\n” but that did not work. I forgot about β€œ\r”

No problem. Sometimes multiple β€œ\n”'s work for me too.

1 Like