Cannot get "List.GetItemAtIndex" to work on a nested array (nested list)

I probably don’t understand data structure in dynamo yet (second day using it). I ran into a problem though, I cannot seem to get item index from anything except a very simple list. A list with an additional data tree breaks the getItemIndex component, causing it to error “Index out of range”. I believe that the index is in range however, and I am misunderstanding something. Please advise! How would you go about using this component in this situation? I would like to get the items with the indexes below from the list above. Thank you for your time.

Revit and script file are available here: (forum won’t let me upload as I am a new user)

I also read this, and seems relevant:

1 Like

Hello Nick,

Thank you for your reply. I believe I’m doing the same thing you are; the data is nearly identical. I tried a more reduced example but still can’t get it to work. What am I doing wrong?


What version of dynamo are you using? Nick enabled list at level feature but you appear to be an older version and not have the feature.

Try changing Lacing to Longest20170817-2


I was using 0.9; could this be the issue? Attempting to upgrade to 1.2.l I believe that this is the issue since list@level was introduced in 1.2. Thank you so much! Will report back if it works

That would be the issue. I believe 1.2 should enable the feature.

1 Like

Yes, I had the computers upgraded to 1.2 and now the @L2 option works. I thought I’d have to write a python node to loop through the list.

Thank you!