Batch change "include" parameter of View Templates


#1

Hello!
I’m trying to use dynamo to set all view templates to not control Point Clouds via view template. I figured setting the override parameter to “0” and therefore false would do the trick, but Dynamo tells me this is not a number.
I’m wondering if Dynamo is reporting only the “Value” column of the view template, rather than the “Include” column.
Does anyone know how to uncheck the box in the “Include” column?

Capture|690x324

Thanks!


#2

Image didn’t upload - can you try again?


#3


#4

Hi,

The output of your element.parameter gives you 4140 parameters, so you probably have more views than just view templates in there, and yes the template is considered a view too. You could narrow it down to just view templates with this node ViewIsViewTemplate in the Clockwork package.

Marcel


#5

Preview the list filter and is view template nodes please.


#6

Hi, all.

It’s definitely the view templates - we have 84 of them (83 as of this posting). The 4140 parameters is the number of templates multiplied by the number of parameters, which varies between each template. I took one and exported its parameters to excel (attached to this post), compared the parameters to what I saw in the View Template window. The mystery parameter to control the “Include” column doesn’t seem to show up.

Maybe I’m approaching this from the wrong direction? Could it be that the “Include” column is not considered a parameter? Or is a parameter for something that is not view related?

Thanks!

ViewTemplate_Cleanup2.xlsx (9.2 KB)


#7

Hi @ahcbbb, see this post here: Setting View Template Includes