Archi-lab Print Settings and Print Range 2 Outputs after saving an re opening

Hi I am using Revit 2017 Dynamo core and Dynamo Revit

The nodes “Print Settings” and “Print Range” are having 2 Outputs after saving and reopening the script.



Anyone know how to get Print Range and Print Setting by Python or how the fix this?

1 Like


Please update your package “” to the last release 2018.13.13.
It will probably fix it.

Nope, it didn’t.



1 Like

Having the same problem here. As far as I understand it that’s because of some changes in Dynamo 2.0.

It seems that the creators of the packages need to update them.

@Konrad_K_Sobon There is one perspective on the release of an update of the package?
Or any way to fix it locally or a Python script that retrieves the same information of the node?

Kind regards

So, I’m trying to get a workaround until the package is updated.

I believe that the “PrintRange” dropdown may be substituted by a simple string “Select”.

The “PrintSetting” dropdown can be substituted by getting the elements of the category.
I used all elements to create a dictionary that can provide the PrintSetting for each sheet.

I’m trying to substitute the last dropdown, “View Sets” with the same way, but then the “Get Views from View Set” outputs ‘null’.
I believe that that is caused because the input goes as a list, and not as a single element(?).
I think that this may be fixed by editing the python script to accept lists, or to “flatten” the list, but I still don’t know how to do that.

Anyone knows how to fix this last part?

Edit: The error was pointing a problem on line 31, so I forced the name of my ViewSet inside the code, and now the input doesn’t do anything.
Not elegant, but it’s working… I’m a beginner on Python and I would be glad to understand what was happening.

You can use a GetItemAtIndex to obtain a singleton or set lacing on longest on Get Views.

1 Like

I tried getting the item and the lacing and none of them worked for me.

But as I said on the edit of my previous post, I could get around by changing the python script that is inside of the “Get Views from View Set” node.

This is related to this: it will be fixed soon (tomorrow)

  • update: Tomorrow will likely not happen since I am waiting on Autodesk to transfer an ownership of my package from one Autodesk account to another (I published it under my old company’s email address that I don’t have access to anymore). That will likely take some time. Sorry.