2019.2.23 Making All Nodes Disappear

Recently when using the package all the nodes in my graph disappear, see image below;

but when is uninstalled the nodes come back, see image below;

Is anyone else getting this problem or can someone help with a suggestion of how to fix it? I’d like to use the Archi-Lab package for the Get Documents node to read information from linked models within my graph.


What version of Dynamo and Revit do you have?

Revit 2019.2
Dynamo Core
Dynamo Revit

It seems like Archilab ships a different version of System.Windows.Interactivity than Dynamo is using - not sure if this has been done for a while or not. @Konrad_K_Sobon will have a better idea.

@Watto did you use past versions of without any issues?

also @Watto do you see any notifications referring to archilab in the dynamo menu - they might pinpoint a cause - you can ignore the revit api warnings. ( I think)

Hi @Watto

You can also get link Documents by using few lines of python:

import clr 
from Autodesk.Revit.DB import*

from RevitServices.Persistence import DocumentManager 



linkDoc, linkName = [], []
for i in link_inst:


Yes, I have used Archi-lab successfully in the past.

I’ll try Kulkul’s python script suggestion to get around this problem.

Thanks for the suggestions

Yes, I have been using System.Windows.Interactivity that comes with MvvmLightLibs. I am using that library for the WPF utilities. I guess I have been using that for the past 3 years at least. The change must have come from Dynamo side, but I can upgrade to match if that will fix the issue.



1 Like

I don’t think we changed our version of this .dll either… so something else might be going on.

@Watto do you also have Pyrevit installed? Can you try updating to the latest version?
What about other addins? Can you try disabling them temporarily?

Hi all, I got the same problem, and it is still a problem even i have disabled all other packages.

I’m experiencing the same disappearing node issue as Watto described when Archi-Lab is installed. I have included some additional information and “work-arounds” in hopes that someone more knowledgeable than myself can identify the root cause.

I’m using
Revit 2018.3
I’ve tried Dynamo and Dynamo
I’ve tried 2019.2.27 and 2019.2.21

When archi-lab is installed, the nodes on the canvas are invisible, right-clicking on the canvas doesn’t bring up a menu, and my menu bar (file, edit, view, etc) is frozen. The only thing that seems to work is the node library, although I can’t add new nodes to an existing graph (or if I can they are invisible to me). If the graph is in Automatic mode, it will say “Run started…” indefinitely.

If I open a blank new graph, I can add one code block, and then Dynamo behaves as described above.

However, I CAN successfully run graphs that contain archi-lab nodes from the Dynamo player. I just can’t edit them.

If I want to edit a Dynamo graph, these seem to be my 3 options:

  1. Uninstall archi-lab
  2. Uninstall archi-lab, open Dynamo, download archi-lab and stay in that Revit session. This seems to work, until I close Revit and open it again in a new session.
  3. Remove archi-lab from my “package” directory, open Revit and Dynamo, paste archi-lab back into the directory, close Dynamo (but not Revit), open Dynamo again. Again, this works until a start a new Revit session.

I’ve used archi-lab for a couple of years now, and this seems to be a new problem. I can’t think of anything obvious on my system that has changed.

1 Like

We got the exact same behaviour, the first time we uninstalled dynamo 1.3 2.0 and so on, reinstalled 1.3 then 2.0 because just 2.0 did not worked, and it fixed it, then 3 weeks later it was fixed by removing the Sysque addin in Revit!!!
crazy right? @Michael_Kirschner2

strange problem for sure - I have seen it without archilab installed as well so I think it has multiple causes - my first thought is that it is potentially a timing issue. I have seen it when Dynamo starts very slowly or when the cpu is under high load during Revit startup. Still tying to reproduce this reliably though.

@Jean-Marc, did the Dynamo logs indicate any dependency conflicts when you had that add-in installed/enabled?

it was not on my computer but I will try and test that tomorrow if possible @jacob.small

1 Like

@jacob.small @Michael_Kirschner2

no message in particular that make sense in the notification or in the console in Dynamo or in logs
We did a couple of test with my colleague and it seems that the following sysque addins and dll are a potential source of this problem. removing them from the folder makes things work again.

where the addin files are
where the dll s are

the excel and opening addin ones that seems to provoke issues on large dyn files

here is the list of my dynamo library that could cause the conflicts

also a link to download the relevant addin and dll files for you to try out!e1dFnaQR!upvPDZN_EdpUxK-fmASUHUqXVRWF-p8OEiLGjZxU1Hs

I am sure the conflict is not the addin or dll itself but more on the relation between the dll loaded in dynamo and the dlls loaded in revit, sometimes there is a wrong mix. We did have the issue on different setup from this one

I hope that helps


1 Like