Archi-lab_Mandrill Create Report node

Hi, I am trying to visualize some data from the “METAMORPHOSIS” - An Open Source Revit Change Analysis Tool”, it´s a tool for comparing Revit projects versions.
The work flow consists on a plug-in that compares and generates a json file with the changes. Then using a dynamo graph and the mandrill package nodes we can visualize the data of the Jason report.
When doing the charts, the final nodes in my graph are these

And when I launch, the mandrill window is empty.
Does anyone knows why this isn´t working?

One thing i find strange is that the node(create report) in the example is different from the node I have in my graph.

Using help on the node it seems that this node as no output

But in the exemple the node create report seems to have an output

Has the node changed ?

If anyone could help me with this questions I would be much appreciated,


Hi Joao,

Do you use Dynamo 1.3 or 2.0 ? Can you verify the version of your Mandrill package ?
The last update is 2019.2.0.

It should look like to this :

This could also be due to a conflict with a Revit plugin.

1 Like

My dynamo version is 1.3 (I think?)

And I installed the lastest version of the package

And my create report node looks like this

For Dynamo 1.3 version, install Archi-lab_Mandrill 2018.0.2.
This should solve your issue.

1 Like

I had to install the 2017.12.4 version, but it worked

Thak you very much!

Ps: by the way, how can i update to dynamo 2.0?

1 Like

I’m glad it worked.
You can download Dynamo 2.0.2 on this webpage under Dynamo for Revit.

1 Like