Archi-lab - Can't Find "Delete Elements" Node



I’m very new to Dynamo and this may be a boneheaded question but I can’t find the Arch-lab node, “delete elements.” I have package 2016.13.4, but whenever I type in delete element the closest node I find is “delete element for Revit DB.” Am I missing something simple here?


Node names change often, which I believe is the reason here.

Konrad may shed some light butnin the meantime try the tool.eraser node in steamnodes.


I added the Steam Nodes, but when I tried to run it nothing happened. Any ideas?


Looks like it worked to me. Basically the output of the tool.eraser nodes is null unless the node is unable to delete an item. See if you can find one of the spaces you set to delete in your model.


I fixed it. Looking at an example I was using to base this off of and I realized I was filtering variables rather than elements. Thanks for the Steam Node tip.


Latest Archi-lab package would have that node under Element.Delete


Thanks @Konrad_K_Sobon!


As of now, it is Elements.Delete
(not Element singular)


I presume we all can forgive @Konrad_K_Sobon that he forgot the s in elements in the node/package he has coded!? Especially now nearly seven months later :slight_smile: