Adding multiple Family types paramaters to multiple family files

For the last days I’m trying to get a Dynamo script working. Put I have tried now a lot of different approaches with out any result. The following thing I am trying to do I want to add multiple type parameters to multiple family files(.rfa)

At the moment I can add multiple type parameters to a single family file. But I need to do this for a lot of families so it is best if it works for multiple. The following problem is when I try it for more than one family file I run into problems.

If someone got a solution it would really help me out. I used some nodes from the Orchid, Clockwork and Rythm package.

I have added the Dynamo file and a picture

Parameter aanmaken.dyn (38.6 KB)

Hi @hugo.paalman

This Parameter aanmaken(For Hugo).dyn (36.2 KB) should work for you. I added List Levels to Parameter.AddFamily and Application Close Document. Make sure you don’t have any families open in Revit while you run script.

2 Likes

No that didn’t do the trick. It stills returns the value to Null and does not read out all of the families that it finds in the given map.

Looks good to me. What does the errors says? Which Dynamo Version your using?

1 Like

The following error: Warning: Parameter.AddParameter operation failed.
A sub-transaction can only be active inside an open Transaction.

I use Dynamo version 2.0.1.
For Revit is use 2018.2

Add Transaction.Start and Transaction.End at each operation.

Nope I still get the same error and Null value…

I tried some other things yesterday but I still don’t get it to work. Which version of dynamo/revit you use?

If I select the file by file path it works. But this is still not realy what I want beacuse I need to add the parameters for at least 100 families. This is at the moment mine solution for adding the parameters only this is for a single family file. Parameter aanmaken.dyn (23.4 KB)

If someone get it to work for multiple family files(*.rfa) please let me know!

@hugo.paalman,

I have tested (and revised) your graph, and I have neither any problems… Are you sure you have the latest version of Orchid? a version named 201.3.1.x?

Parameter aanmaken.dyn (28.3 KB)
Capture

Just a hint… I use Wormhole to catch backup files
–for Revit 2019, this can be downloaded here
http://wiip.biz/node/8537

4 Likes

@ erfajo

Realy strange I installed the package a week ago but I re-installed the Orchid package now and for some reason it’s working fine. Thanks for the help and you to @ Kulkul! I think I install the wrong version in the first place…

aha then you might be hit by this

please then move the acknowledgement to @Kulkul, he “solved” it as the first in that case :slight_smile: