AdaptiveComponent.ByPoints giving "Null" output

Hi everyone, I am trying to model a structure using adaptive family (done with 3 adaptive points). When I run dynamo, the tool AdaptiveComponent.ByPoints is giving me a “Null” output.

Below is a screenshot of what I did, please advise.

Hello @sarah.matta
Welcome to Dynamo Community.

have you tried by changing the level 2 (@2) or @1
Hope this will solve your problem

image

Hello thx alot, yes I tried it and still giving me Null:

The number of Points in the sublist must match the number of adaptive Points in the Family. Do not use this knot “List.Flatten”

1 Like

yes it matches, i have 60 points in total

what? the Family has 60 adaptive Points !!!

ah okay now i get what you said before, yes the number of points in the sublist matches the number of adaptive points in the family (3 points)


Apadtive2

the Points need to be list of list .[each list must be inside list]

1 Like

Hello Ramez how are you?? (I dont know if you remember me we were in the same company you did dynamo training for us). I tried to use list.Map as you suggested, didnt work too then I used the in house tool that converges the arraylist to point and it worked.

1 Like

Hi Sarah. sure i remember you :hugs:, nice to meet you again. Good is the problem solved.

1 Like