3D rooms with springs nodes (ꟿ FamilyInstance.ByGeometry)

Hello everyone!
I’m trying to create 3d rooms in the project. I saw a similar situation https://forum.dynamobim.com/t/3d-room-color-colour-coloured-volumes-using-spring-nodes-direct-shapes/34997

. where it was proposed to use the node "ꟿ DirectShape.ByGeometry " from the same package. It worked well, but I need the ability to edit the received elements. In this regard, I decided to try using “ꟿ FamilyInstance.ByGeometry”. The problem arose from where I did not expect) When generating families, units are read as feet, and it is necessary to get millimeters. Can someone tell me how to fix it? I’m not very good at python, I tried to fix the original python script a little, but everything broke)
I attach the script and thank you in advance for your help!)
Rooms_To_DirectShape_Trying family.dyn (53.6 KB)

Try scaling down the geometry prior to sending to the node for family creation.

I tried this option before, but there were problems with shifting elements as a result of scaling, I worked with the coordinates and got the correct position, but broken ones began to appear and at some point the geometry was lost. If there is an opportunity, I would like to somehow correct the conversion in the node itself

1 Like

The fix will be to scale at the correct location, either in the Python code or before sending the geometry into the node, or to work with an imperial units. This has also been resolved in a future Dynamo release, so make sure your Revit is fully updated before you put too much into this as if not the next time you update you may have the stop working again. All of that is to say that any code alterations will require management of the deployed package or which Python is executed.

I recall that the scaling should occur at the insertion point of the family geometry, which I believe to be minimum point of the bounding box. See if scaling there (or the centroid, or center of the base face of the bounding box) works.


Hi @Storm I assume you are in 2022…if that the case then you could also try this one here from Synthezise toolkit…


1 Like

Thank you fro ur answer, can u tell me which version of Archi-lab did u use? I have this node, but there are some differents from ur. This is my one

1 Like

yes sure in my example i use synthezise, clockwork, and genius loci for graphic and view…as you can see i set the name after i had create these families, it should be done with synthezise itself…i couldnt get it to work, the most overcomplicated node i know :wink: :wink: think the python is almost 2300 lines …anyway i would do it with directshape much faster…specially when it is for 3D rooms

Thanks for the answer! I didn’t see at first that you specified packages) Now for some reason “K-Family Insert” gives zeros, but I’ll try to figure it out.

Yes its can sometimes be hard work with that node…be sure list level is set to @@L3 and lacing to shortest…

forum3droom.dyn (55.6 KB)