VS Code - Revit API autocompleat doesn't work

Hi, i have a problem with autocompleat in VS Code. I set my pylance extra paths:

and autocompleat works but i want to ask… It is “normal” that autodesk function don’t have info and nothing after “.”?


Pyrevit works better

Do you have an idea what could be wrong? Maybe someone could show his VS Code settings?

Asked and answered many times:
try this one Python autocomplete? - #3 by Yien and its links
Or search for autocomplete in the search box :wink:

1 Like

Yeah, i know. But i used all methods from forum. This linked topic too… Nothing changed… :frowning:

Try this one then

One thing that could solve it right away is disabling pylance