Trouble with geometry not projecting onto surface

I seem to be incapable of successfully getting around this hang up. But this script is crapping out at the surface.projectinput onto. Why is the list an empty list? The surface is sloped, not sure if that is the issue or not, but it is above the Z coordinate of the geometry for sure since the geometry is at elevation 0 and the surface i selected is around 300 in the Z direction. I added two more flatten nodes shown below, but nothing seems to want to work because the projection node is not working. What am I missing. Thanks!

Perhaps your geometry (point) is above your surface. Try inverting your vector z axis node with a vector.reverse node.

1 Like

Jackpot! it worked! It doesnt make any sense, considering the coordinates of the elements involved but it worked. lol I am really more concerned with WHY it worked than it did though. i mean, the Z projection point is positive, why does the Z vector have to be negative?

Weird indeed. Can you share a paired down Revit file and a DYN?

My only guess is that the project onto uses a vector relative to the normal of the surface and that surface you selected has an inverted normal (meaning it’s been turned inside out). That could cause the vector to need to be reversed vectors are relative to the surface.

Try this… test.rfa (1.9 MB)