Tool.ElementsInGroup not working - SteamNodes

Hi people,
Does anyone know why I am getting a ‘null’ when I try and get the geometry from this group?

Kind regards

Personally I would need the Revit file to troubleshoot it. Can you build a similar model setup with matching types and post somewhere we can download it from?

Hi Jacob,

Here is a drop box link to a Revit model with the family inside.

Looks like there is an issue with auto lacing with the node in 2.0.2 (I haven’t tested other builds). The node “List.Equals” inside the custom node needs to be set to ‘longest’ lacing in order to ensure the tool tests at the correct level - otherwise the list of the item will never be equal to the item itself. The exact node to be changed inside of the custom node is the only node in a group here:

Thought this was worth making a note at the GitHub, so you can follow along here: https://github.com/dimven/SpringNodes/issues/55

Hi Jacob,

Thank you for having a look but it still does not give me a output. First I did what you said above and changed ‘List.equals’ to ‘Longest’ however there is still no output. I tied looking at the other nodes as well and changed the values to ‘longest’ . I have tried extended the code to see if that helps (Instead of typing the names of the groups". See below:

What I might try next is copying out the custom code to the external script and then use ‘watch’ to see how the data is flowing through the nodes and where it goes wrong. Inside the custom code, we can’t see what is going on.

Ok perhaps the issue is in collecting the groups in the first place. See below
image

I wonder if anyone has been successful in using this node in dynamo version 2.0.3

?

Ok The script below works :slight_smile:

Also, the 1.0 version of dynamo python scripting was having a little trouble. I just copied in the original script from the custom steams node and it works with multiple groups :slight_smile:

1 Like

The one edit I made had the graph working in 2.0.2 and 2.1.0 without issues… I did skip over 2.0.3 though.

1 Like

Your solution just worked for me, I only had to additionally substitute the custom code node “flatten” by the list Flatten node (inside of the Tool.ElementsInGroup). I’m using 2.0.3.

thank you,