The Values of the levels in a room tag


#1

Hallo everyone,
I am trying to get in a roomtag in revit the values of the finish floor level FFL… I mean, we can get in the room tag some info like: Name, Area, volume, Room Height… etc, but how can I build in Dynamo a parameter, which gives us for example: the value of finish floor level in every room tag… I have started in Dynamo with these codes but i could not do further… I hope of your help!! Thans alot
Haseeb


#2

@T_Pover


#3

I don’t know a lot about rooms but floor finish and level are parameters that are associated with a room as is right? I don’t see why you would need dynamo for this. Perhaps you could elobrate a bit further, maybe some screens from Revit showing what parameters you want to transfer.


#4

I am sorry, that everything is written in German. My question is: In this room tag I wanna get the values of the levels automaticelly. I used to write them as a Text.
For instance: OKFFB refers to the finish floor level, and in my example it is the first Floor level. In family parameter in revit i can get just the name of the level, but what i want is the Value !!!

01


#5

In Revit, make a new shared parameter for ‘finish floor elevation’ and add it to your project (associated to rooms) and room tag and load the tag into the job.

In Dynamo get the parameter value for ‘finish floor level’ as you did before and then get that level’s elevation using another element.getparametervaluebyname node. Then use an element.setparameterbyname to set the rooms 'finish floor elevation.


#6

What Jacob said:

Element.Level is from Clockwork package


#7

@T_Pover @JacobSmall
Thanxxxxxxxxxxxxxxxxxxxxxxxx alot!! It works !! Vielen Lieben Dank Leute


#8

Hi T_Power,

I saw this code and i’m also need this one in a project. but it gives met te error parameter nog found.

I thing i did everything is said. But don;t know waht is going wrong?

Thanks


#9

Are you sure you set it to be an instance parameter?


#10

Hi,

First of all, thanks for the response!

How do you make that parameter. How i did it in my picture? because that didn’t work

Thanks


#11

I already find it.

The shared parameter was a text instead of a number. So now it is working :slight_smile: