SynchronizeWithCentral in Document return false


First off all i’m new to Dynamo so sorry for any wrong doing beforehand.

I’m trying to build a graph that:
*Opens a list of rvt files
*Detach the files from central
*Sync and relinquish
*Save the files
*Close the files

I’m using Rhythm and Genius Loci packages.

The graph is working up to point where I connect the boolian, set to true, to the detachFromCentral input of the OpenDocumentFile node, as illustrated below.

What am I missing

Thanks in advance.

Hi @CaAnd,

Welcome to the Dynamo forum.

It’s a Revit thing and not a Dynamo problem.
It’s not possible to synchronise a detached model. You need first to save it and after you will be able to synchronize it.

Big thanks for a fast reply.
That was stupid of not think that the order of what I’m doing in Revit needs to be the same in Dynamo.
But now its working.

Just and extended question. How can I controll the preset for opening worksets? I like it to be set to last Viewed or All, but after I run the graph above it has changed to Specify.
2021-01-29 14_51_28-Autodesk Revit 2021.1.1 - Project1 - Sheet_ 01 - OPPDRAGSINFORMASJON

I will try to add this option in the next release of the Genius Loci package.
Indeed the default is “Ask User To Specify”.

Is it possible to change this my self in the Pyhton code of the node for now?

Of course. :slightly_smiling_face:
And don’t forget to post your improvements. So the community can use better nodes.

1 Like

In case you haven’t made the modification yourself, the custom node was updated a few days ago.

No I didn’t. Thanks for the good work.