Solid Lofting uncorrect

dynamo

#1

Hello,everybody~The Dynamo reports an error when I using the Solid by Loft (using curves and guidelines) node,and it‘s unresponsive when using the node Solid.by Sweep,as shown in the picture:



#2

Could you post screenshots of the errors?


#3

Here is the screenshots:


#4

and when I use a straight line as guideline, it’s right…


#5

Try:


#6

Looks like you need to put your circle on the outside edge of the curve instead of the center point. Using the center point creates a fold in the shape so it self intersects which is a no-no.

To confirm, try to offset the polycurve by -1* the radius of the circle, so the curve is on the inside edge of the circle.


#7

WOW!!!It works now!Thank you!But what’s the different between polycurve and nurbscurve?Once I use a polycurve as path, the Dynamo will not respond…


#8

I tried and found that the polycurve cannot be used as a path when the solid was generated,but I still want to thank you~


#9

hello Polaris
sometimes polycurve will work but not always see also my image.
also nurbscurve will not always work (most of the times for this it works better than polylines)
the curve needs to intersect to surface


#10

Youre welcome If a comment solved your problem,
mark it as solution (and maybe leave a like here and there).


#11

OK,Thank you very much~~~