Setting Workset Parameter In View Filters

When I tried to use the Workset parameter as my filter parameter with the FilterRule.ByRuleType node, the value would always be blank regardless of how I tried to apply the value to the node. I tried just a string with the Workset name, tried looking up the value by the string name for the Workset and even the DB value.

I finally gave up and created a project parameter that worked fine.

When I was trying Workset I would use “Workset” in the code block instead of “FT_Workset”

This would be the result

I have a feeling it’s in the way I’m setting the parameter to “Workset” with all different types of parameters we have available (Built-in, Project, type or instance)

Hi @ScottWeiter5186

Have you tried feeding in the id of the workset?


Tried that and I’m going to have to go back and try it again to remember if it gave me an error or also returned blank for the workset.

Hi @ScottWeiter5186

I’ve seen that if the categories set in the project parameter don’t match exactly those in the filter, things get messed up.
But since you use Workset (which is set automatically) this can’t be the problem, can it?


Thanks so much Marcel. I could swear I tried the Workset ID before. But I went through and tried it again and works perfect!

1 Like

Guess I shouldn’t of said tried it again, had I tried it in the first place, I would of seen that it worked.

Hi Scott, what packages are you using ?