Rhynamo nodes issue

Hello everybodies,
I would like to use this script but Dynamo is telling me that some of nodes are unresolved!
Fact is, i don’t understand cause i have this kind of nodes includ in my latest version of Rhynamo.
If you have a solution to resolve this kind of issue!
Thank you very much!

RhynamoExample.dyn (71.1 KB)

Unresolved means that the package is not installed… if you restart your pc most will probably go away… if not replace the yellow nodes in the graph with the corresponding nodes from the package… :slight_smile:

1 Like

Thank you!
I’m gonna try that and tell you if it’s working!

Hello again,
So I replace the yello nodes which were unresolved by the nodes of the rhynamo package.
But it still doesn’t work. :sweat_smile:
Do you have some other tips please?
Thank you very much!
RhynamoExample.dyn (49.2 KB)

What does the yellow “Error” read in the yellow node to the far left?

For exemple the first Yello node is telling me this : "Avertissement:RhinoObject.Get_RhinoLayerNames l’opération a échoué.
Impossible de charger le type ‘Rhino.DocObjects.ModelComponent’ à partir de l’assembly ‘Rhino3dmIO, Version=5.1.30000.14, Culture=neutral, PublicKeyToken=null’.

Which translates too? (In English please)

Sorry: look the translation :
Warning : RinoObject.Get_RhinoLayerNames operation failed.
Can’t charge the type ‘Rhino.DocObjects.ModelComponent’ from assembly ‘Rhino3dmlo, Version=5.1.30000.14, Culture=neutral, PublicKeyToken=null’

My humble guess without having tried the package is that your Rhino version is not compatible with Rhinamo…

Okay! Thank you!
I’m gonna check that and tell you later!

So I checked with a demo on Proving Ground and actually the process was done with rhino 5.0 and I use the same!
The question is still unsolved yet!
So If you have or anybody else has tips about that Topic, feel free to share with me!
Thank you very much

If you read the description for Rhynamo it is not yet updated to support Dynamo 2.0


Tested in 1.3 and it works without a hitch…

HAHA ok! I didn’t see that i’m gonna try with a nother version of dynamo!
i’ll tell you if it’s working on my side!
Thank you very much!

GG @Jonathan.Olesen!
Thank you very much!