Problem With "Intersection.GeometrySplit" node from LunchBox

lunchbox

#1

Hi Guys,

I need your help. I’m experiencing this issue with the “Intersection.GeometrySplit” node from LunchBox. I’ve tried to feed him with just one surface to split and several element as splitting geometry: no problem at all. But if i try to feed it with multiple surfaces there is no way is going to work, and my Dynamo is always crashing.
I would like to know if you have experienced the same issue and if you know a way to get over it, or if you can suggest me an alternative path. Again what i need is to be able to split multiple surfaces with multiples cutting elements in one shot. As usual thank you in advance.
I post a screen shot of the first condition: here is when it works with just one surface

Here in the second one you can see me tring to feed the node with multiple surfaces (can do it so can’t take the screenshot)

thank you in advance for your time.


#2

Ciao @Claudio_Vittori_Ant2 can you post a sample rvt file and your dyn


#3

Yes of course, sorry about it. Actually i’ve been working on the script even today and i found out the is the node “Intersection.GeometrySplit” is not working both on Dynamo 1.2 and 1.21 on Revit 2017.
I can’t make that node stable even if i try to change cutting geometry (Plane and Lines for example).

Here is the example
Mass Sample.rfa (1.3 MB)
Script.dyn (37.7 KB)
Thank you


#4

@Claudio_Vittori_Ant2 You are right. The node behaves in a very strange way even in Dynamo 1.3 and Revit 2018.