Polycurve.ByJoinedCurve operation failed

Hi People,

I have a room finish boundary that I am trying to produce a polycurve from and I am getting this error:

Does anyone know why? Clearly I am feeding a list of curves so it is not empty. Any thoughts are greatly appreciated.

Kind regards

Try using the node version and translating to Design Script via node to code. My guess is that it is working at L3 (only contains a list) or L1 (only contains elements), but it’s hard to know without seeing more.

Thank you JacobSmall but what do you mean by node version? Do you mean converting the functions of the script to their node equivalent? I have tried that and I still get the same error. I will try testing the lacing as you mentioned above to see if that helps.

Hi Jacob, find attached script and mock revit file.AutoPlanViewCreator_CropBox_RoomPerimeter_ForumQuestion.dyn (132.3 KB)Project2.rvt (488 KB)

works for me:

i only changed the string that your are searching:
from "APARTMENT-TEST- to APARTMENT-TEST (now without - at the end)

its also working, but i have changed the name of the group:

What did you change the name of the Group too? Can you show me in the Revit interface your settings?

I think it has something to do with the levels and scaling…
I copied the rooms down to the Datum and it works, but when I try and run the script for upper levels (L39) for example, it does not work. Is there some setting in dynamo I need to adjust so that the script works? I have tried changing the geometry scaling to the highest setting:

But it still does not work.

Dont remember the string, but there was only one group in your file…so i collected the data from this group.
Don’t think your problem has something to do with Geometry Working Range.

I copied the groups to the datum and it works but when I start changing where they sit in the levels, it works for some of the groups and not others. It is very strange. If you try making a group and then try changing the height (Level 07 compared with L39) do you get an error?
It is driving me bananas

If i only copy paste the group to another level it works.
If i change the offset height of that new group, the script can’t find the FinishBoundary. The result is an empty list. Like in your first picture.
So …the problem is the Room.FinishBoundary node.
I think this nodes needs the right “height of caluclation”. So if your group offset from level is 1m…you need to set the calculation height of the level to 1m.