Points are likely coincident when asking for geometry


After selecting all kinds of objects I’d like to get the polylines and return the length and radius in the polyline (if it contains curves). My model works for some drawings, but sometimes it returns a null when asking for the geometry (number 44 in the list), which causes problems later on.
The error is that points are likely coincident. I don’t know how to fix this, I’ve already tried overkill and changing the geometry scaling.

Does anyone know how to solve the problem?

Hi @nicolas.fernandez ,

The Civil3DToolkit package has a node which should solve this issue.
Search for: PolylineExtensions.ObjectByGeometry in the Package.


You may just need to remove the nulls from your list.

By “changing the geometry scaling” do you mean changing it from medium? If so, then it should be left at medium, otherwise issues like this can happen.

No I set it on medium, but the problem still occurs…

I could do that, but won’t I be deleting polylines that I need information from? I also don’t how to check which line i will be removing.

Potentially, yes, but it’s impossible to say at this point. The first step would be to identify those lines and determine why they’re returning null geometry. It may be that they can be safely ignored. It may be that you need to collect those specific geometries another way.

Okay, thanks! I don’t really know what gives the problem, but will try to find out how to determine the lines.

maybe toggle the “is closed” property for all polylines

I had the same error message the other day. For some reason making a copy of the polylines and using “CONVERTPLINES” to change the copy into 3d polylines fixed the issue. I am unsure why.

I’ve found another solution without having to convert it to a 3d polyline.
By using MAPCLEAN and selecting Delete duplicates, Simplify Objects, Zero Length Objects and Erase Dangling Objects the problem seems to be solved.


I’ll have to try this as well. Thanks for sharing Nicolas!