Please don't trim my zeroes

I’ve got a list of numbers; well, they are supposed to be numbers turns out they are strings. So, I got to convert them but then it trims the zeroes off the front. I’ve already gone to a lot of trouble earlier in the graph to add those zeroes on the front so I’d really rather leave them or should I move the leading zeroes node in between setting the parameter?
Can I convert them to a number and keep the leading zeroes where they are at?

In what context do you need leading zeros on a number? That’s not really a format you see and I don’t think Revit has any way to handle them internally. I think they would have to be strings.

1 Like

you were right, sorry about that. the parameter did need to be a string