Placing objects perpendicular to corridor feature line using CorridorFeatureLine.CoordinateSystemByStation

Hi everyone, first post on the forum :grinning:. I’m trying to place posts along a corridor using a feature line as the reference. The posts need to be perpendicular to the feature line and I’m currently using the CorridorFeatureLine.CoordinateSystemByStation to create a coordinate system at specific stations along the line where the posts will be placed. When I run the code I get the error: “Unable to create Line. Points are likely coincident” (Refer to the snapshot). Any assistance will be greatly appreciated. Thanks.

Try dropping the first item in the range with a List.Drop node. If that doesn’t work try also dropping the last (use a -1), and of that doesn’t work post a file that reproduces it and the graph (if need be use a 3rd party hosting app such as Dropbox, google drive, onedrive, etc).

Hi @rozina.myoya

Could you switch on the preview bubbles for all the nodes and share the image again?

Hi Jacob, thanks for getting back to me. Turns out the issue was a duplicate point in the range. I fixed it using the Point.PruneDuplicates function.

1 Like

Hi @Kulkul, here’s another screenshot with the preview bubbles. I rerun the script and managed to get a few coordinate points, but I’m still getting null outputs. I don’t understand why, because the corridor feature line is a complete line with no discontinuities so I don’t understand why a solution cannot be found at those null points.

Based on your resulting X-values I suspect Geometry Scaling errors. any chance you could expand that yellow warning for us?

1 Like

Hi @jostein_olsen, would that mean having to convert the coordinates to dynamo coordinates? I’ve heard that’s common when working with Revit, I was hoping it wouldn’t apply when working with Civil 3D. The current error is “Could not find parameter at Point”.

Well no, not exactly, but have a read through here. 'PolyCurves may be branching' caused by Geometry Scaling setting?. Maybe @JacobSmall or @Paolo_Emilio_Serra1 can shed some light. Could be something else entirely, but that is my best guess.

1 Like

Large coordinates definitely have an impact on civil workflows - the question is how much of one. I haven’t gotten my head around the extents of the issue yet as I only get to dabble in Dynamo for Civil 3D And Dynamo for Alias - the firms I support design builds not roads or cars.

This doesn’t look to be that issue though, based solely on the error message. What version of Dynamo for Civil 3D and what
Civil 3D build are you running?

Can you provide a minimal DWG to reproduce (delete all content but that corridor)?

Hi @jostein_olsen you were absolutely right! Thank you for referring me to the linked discussion. I changed the Geometry scaling setting form “Extra large” to “Medium” and it worked (Refer to the link). No more Null points. Thanks for the input everyone :slightly_smiling_face:

Hi @rozina.myoya

Could you please drop here dwg file and dyn file? I’m thinking of a workaround here may be it will fix your issue.

OMG!! Thanks
I spent a whole day trying to figure out what was causing null values.
Just reduced my Geometry Scaling and it worked!
thak you very much