Place Specialty Equipment Tag With Leader Bug

Hello all,

I am trying to tag specialty equipment in a particular view after placing it. I have tried almost all of the tag nodes (all otb and 2-3 from various packages). Each of the nodes place tags at the origin of the project.

I found a bunch of working examples for other categories so I tagged all of the doors in the view and they are working fine. In the first image below you can see a bunch of leader lines running from the center. If you look at the doors though you will see they are tagged appropriately.

Any Ideas?

Place Sign and Tage them.dyn (582.3 KB)

Link to sample rvt file

I found Creat Independent Tag from GeniusLoci’s package (its an updated version of archilab’s Creat Annotation Tag). As you can see in the image below I was able to get the tags to place in the correct location however, they do not have leaders. I edited the code to turn on leaders and all of the tags are again placed at the origin (see image 2).

Does anyone know if you can turn on a leader after the tag has been placed? I cannot find it in the API. I was only able to find HasLeader Property (Whether the tag has a leader or not.)

Since my OP I have tried other categories (in addition to doors) and they are all working fine. This behavior seems to be isolated to specialty equipment.


Dynamo core
Dynamo Revit



After sleeping on it and beating my head agaienst a wall I added a Transaction.End after the elements are created (Springs.HostedInstance.ByPoints) and it is now working. I guess there was just a hang up in the transactions.

Hi @Steven! Could you share some ideas on how you modified the 'Create.Independent Tag" node to create you leaders as well? I’m not a coder myself so if you can share your modification script, i’d appreciate it.

Check out my recent post related to the same kind of trouble

Hi @ppokharna,

I did not change any of the code. After I placed/created the new elements I added a Noded called Transaction.End. This node will stop all Revit Transactions before starting the next portion of the script. Sometimes Revit just moves too fast for its own good.